Home Technical Support

FactSet OnlineComponents Error (EID2004)

Symptom

FactSet OnlineComponents Error ID 2004 is displayed when starting FactSet Workstation:



Cause

FactSet Workstation is attempting to load an updated version, but some of all or the necessary files are missing.

Resolutions

If you continue to experience FactSet OnlineComponents Error ID 2004, then delete the FactSet Workstation update files using the FactSet Troubleshooting Utility advanced option Clear Update Files:

  1. Close FactSet Workstation, Microsoft Excel, Word, PowerPoint, Outlook, OneNote, Adobe Reader and Acrobat.
  2. Click on the following link https://support.factset.com/
  3. Click SAVE (exe) under the ‘FactSet Troubleshooting Utility 3’ section and FactSetTroubleshootingUtility.exe will be downloaded.
  4. Run FactSetTroubleshootingUtility.exe
  5. Click Advanced
  6. Click Run for Clear Update Files
  7. Click Finish and then close the FactSet Troubleshooting Utility.
  8. Once complete, start FactSet Workstation and login when prompted.

If you continue to experience issues, please locate the FactSet Add-in Manager blue and white plus sign icon within the Windows taskbar tray and select Send Diagnostic Report, and then contact FactSet Support